Adobe AIR < 2.7.1 Multiple Vulnerabilities (APSB11-21)

high Nessus Plugin ID 55805
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains a version of Adobe AIR that is affected by multiple vulnerabilities.

Description

According to its version, the instance of Adobe AIR installed on the remote Windows host is equal or prior to 2.7.1. It is, therefore, affected by several critical vulnerabilities :

- Multiple buffer overflow conditions exist that allow a remote attacker to execute arbitrary code.
(CVE-2011-2130, CVE-2011-2134, CVE-2011-2137, CVE-2011-2414, CVE-2011-2415)

- Multiple memory corruption issues exist that allow a remote attacker to execute arbitrary code.
(CVE-2011-2135, CVE-2011-2140, CVE-2011-2417, CVE-2011-2425)

- Multiple integer overflow conditions exist that allow a remote attacker to execute arbitrary code.
(CVE-2011-2136, CVE-2011-2138, CVE-2011-2416)

- A same-origin bypass vulnerability exists that allows a remote attacker to obtain sensitive information.
(CVE-2011-2139)

Solution

Upgrade to Adobe AIR 2.7.1 (2.7.1.19610) or later.

See Also

http://www.nessus.org/u?46d1fce8

http://www.adobe.com/support/security/bulletins/apsb11-21.html

Plugin Details

Severity: High

ID: 55805

File Name: adobe_air_apsb11-21.nasl

Version: 1.16

Type: local

Agent: windows

Family: Windows

Published: 8/10/2011

Updated: 6/27/2018

Dependencies: adobe_air_installed.nasl

Risk Information

VPR

Risk Factor: Critical

Score: 9.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:air

Required KB Items: SMB/Adobe_AIR/Version, SMB/Adobe_AIR/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/10/2011

Vulnerability Publication Date: 8/10/2011

Exploitable With

Core Impact

Metasploit (Adobe Flash Player MP4 SequenceParameterSetNALUnit Buffer Overflow)

Reference Information

CVE: CVE-2011-2130, CVE-2011-2134, CVE-2011-2135, CVE-2011-2136, CVE-2011-2137, CVE-2011-2138, CVE-2011-2139, CVE-2011-2140, CVE-2011-2414, CVE-2011-2415, CVE-2011-2416, CVE-2011-2417, CVE-2011-2425

BID: 49073, 49074, 49075, 49076, 49077, 49079, 49080, 49081, 49082, 49083, 49084, 49085, 49086

EDB-ID: 18437, 18479