Google Chrome < 13.0.782.107 Multiple Vulnerabilities

High Nessus Plugin ID 55765


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than 13.0.782.107. As such, it is potentially affected by several vulnerabilities :

- An unspecified error exists related to extension installation and confirmation dialogs. (Issue #75821)

- A stale pointer issue exists related to bad line box tracking and rendering. (Issue #78841)

- A security bypass issue exists related to file download prompts. (Issue #79266)

- A string handling issue exists related to the HTTP basic authentication dialog box. (Issue #79426)

- Developer mode NPAPI extensions do not always prompt a user before installation. (Issue #83273)

- A local, unspecified path disclosure issue exists and is related to the GL log. (Issue #83841)

- Extensions' homepage URLs are not properly sanitized.
(Issue #84402)

- The browser's speech-input element is not always on the screen at required times. (Issue #84600)

- A re-entrancy issue related to the GPU lock can cause the browser to crash. (Issue #84805)

- A buffer overflow exists in the inspector serialization. (Issue #85559)

- Use-after-free errors exist related to the Pepper plugin, floating styles, float removal, media selectors, Skia, resource caching, HTML range handling, frame loading and display box rendering that can cause the browser to crash. (Issues #85808, #86502, #87148, #87227,# 87548, #87729, #87925, #88846, #88889)

- An out-of-bounds write error exists related to the Internal Components for Unicode (ICU). (Issue #86900)

- Out-of-bounds read errors exist related to text iteration and Skia paths. (Issue #87298)

- A cross-frame function leak exists. (Issue #87339)

- Access to internal schemes is not properly enforced.
(Issue #87815)

- Client side redirect targets may be leaked to remote locations. (Issue #88337)

- Const lookups can cause the V8 JavaScript engine to crash. (Issue #88591)

- Certain PDF files with nested functions can cause the browser to crash. (Issue #89142)

- The same origin policy is not properly enforced which can lead to cross-origin script injection and other cross-origin violations. (Issues #89520, #90222)


Upgrade to Google Chrome 13.0.782.107 or later.

See Also

Plugin Details

Severity: High

ID: 55765

File Name: google_chrome_13_0_782_107.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2011/08/04

Modified: 2016/05/16

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/08/02

Vulnerability Publication Date: 2011/08/03

Reference Information

CVE: CVE-2011-2358, CVE-2011-2359, CVE-2011-2360, CVE-2011-2361, CVE-2011-2783, CVE-2011-2784, CVE-2011-2785, CVE-2011-2786, CVE-2011-2787, CVE-2011-2788, CVE-2011-2789, CVE-2011-2790, CVE-2011-2791, CVE-2011-2792, CVE-2011-2793, CVE-2011-2794, CVE-2011-2795, CVE-2011-2796, CVE-2011-2797, CVE-2011-2798, CVE-2011-2799, CVE-2011-2800, CVE-2011-2801, CVE-2011-2802, CVE-2011-2803, CVE-2011-2804, CVE-2011-2805, CVE-2011-2818, CVE-2011-2819

BID: 48960

OSVDB: 74228, 74229, 74230, 74231, 74233, 74234, 74235, 74236, 74237, 74238, 74239, 74240, 74241, 74242, 74243, 74244, 74245, 74246, 74247, 74248, 74250, 74251, 74252, 74253, 74254, 74255, 74256, 74257, 74258