SuSE 11.1 Security Update : libsndfile (SAT Patch Number 4902)

Medium Nessus Plugin ID 55745


The remote SuSE 11 host is missing one or more security updates.


An integer overflow in libsndfile while processing certain PAF files has been fixed. CVE-2011-2696 has been assigned to this issue.
Additionally a divide by zero error (CVE-2009-4835) has been fixed.


Apply SAT patch number 4902.

See Also

Plugin Details

Severity: Medium

ID: 55745

File Name: suse_11_libsndfile-110719.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2011/08/01

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libsndfile, p-cpe:/a:novell:suse_linux:11:libsndfile-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/07/19

Reference Information

CVE: CVE-2009-4835, CVE-2011-2696