SuSE 11.1 Security Update : libgnomesu (SAT Patch Number 4805)

High Nessus Plugin ID 55484


The remote SuSE 11 host is missing one or more security updates.


The libgnomesu pam backend did not check the return value of the setuid() functions. Local users could exploit that to gain root privileges. (CVE-2011-1946)

Note: this is just a re-release of the previous update to fix a regression unrelated to the security issue.


Apply SAT patch number 4805.

See Also

Plugin Details

Severity: High

ID: 55484

File Name: suse_11_libgnomesu-110629.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2011/07/01

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libgnomesu, p-cpe:/a:novell:suse_linux:11:libgnomesu-lang, p-cpe:/a:novell:suse_linux:11:libgnomesu0, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/06/29

Reference Information

CVE: CVE-2011-1946