SuSE 11.1 Security Update : wireshark (SAT Patch Number 4476)

High Nessus Plugin ID 54994


The remote SuSE 11 host is missing a security update.


This update to wireshark version 1.4.5 fixes the following security issues :

- Resource Management Errors. (CWE-399, CVE-2011-1590)

- Buffer Errors. (CWE-119, CVE-2011-1591)

- Numeric Errors (CWE-189, CVE-2011-1592)


Apply SAT patch number 4476.

See Also

Plugin Details

Severity: High

ID: 54994

File Name: suse_11_wireshark-110503.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2011/06/08

Modified: 2017/06/05

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:wireshark, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/05/03

Exploitable With


Core Impact

Metasploit (Wireshark packet-dect.c Stack Buffer Overflow)

Reference Information

CVE: CVE-2011-1590, CVE-2011-1591, CVE-2011-1592

CWE: 119, 189, 399