Apache 2.2.x < 2.2.18 APR apr_fnmatch DoS
Medium Nessus Plugin ID 54646
SynopsisThe remote web server may be affected by a denial of service vulnerability.
DescriptionAccording to its banner, the version of Apache 2.2.x running on the remote host is 2.2.18. It is, therefore, affected by a denial of service vulnerability due to an error in the fnmatch implementation in 'apr_fnmatch.c' in the bundled Apache Portable Runtime (APR) library.
Successful exploitation of this vulnerability requires that 'mod_autoindex' be enabled.
Note that the remote web server may not actually be affected by this vulnerability. Nessus did not try to determine whether the affected module is in use or to check for the issue itself.
SolutionUpgrade to Apache version 2.2.19 or later. Alternatively, ensure that the 'IndexOptions' configuration option is set to 'IgnoreClient'.