Apache 2.2.x < 2.2.18 APR apr_fnmatch DoS

Medium Nessus Plugin ID 54646


The remote web server may be affected by a denial of service vulnerability.


According to its banner, the version of Apache 2.2.x running on the remote host is 2.2.18. It is, therefore, affected by a denial of service vulnerability due to an error in the fnmatch implementation in 'apr_fnmatch.c' in the bundled Apache Portable Runtime (APR) library.

Successful exploitation of this vulnerability requires that 'mod_autoindex' be enabled.

Note that the remote web server may not actually be affected by this vulnerability. Nessus did not try to determine whether the affected module is in use or to check for the issue itself.


Upgrade to Apache version 2.2.19 or later. Alternatively, ensure that the 'IndexOptions' configuration option is set to 'IgnoreClient'.

See Also





Plugin Details

Severity: Medium

ID: 54646

File Name: apache_2_2_19.nasl

Version: $Revision: 1.15 $

Type: remote

Family: Web Servers

Published: 2011/05/25

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/05/19

Vulnerability Publication Date: 2011/05/19

Reference Information

CVE: CVE-2011-1928

BID: 47929

OSVDB: 73383

Secunia: 44661