CVE-2011-1928

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The fnmatch implementation in apr_fnmatch.c in the Apache Portable Runtime (APR) library 1.4.3 and 1.4.4, and the Apache HTTP Server 2.2.18, allows remote attackers to cause a denial of service (infinite loop) via a URI that does not match unspecified types of wildcard patterns, as demonstrated by attacks against mod_autoindex in httpd when a /*/WEB-INF/ configuration pattern is used. NOTE: this issue exists because of an incorrect fix for CVE-2011-0419.

References

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=627182

http://lists.opensuse.org/opensuse-security-announce/2011-11/msg00011.html

http://mail-archives.apache.org/mod_mbox/httpd-announce/201105.mbox/%[email protected]%3E

http://mail-archives.apache.org/mod_mbox/www-announce/201105.mbox/%[email protected]%3e

http://marc.info/?l=bugtraq&m=134987041210674&w=2

http://openwall.com/lists/oss-security/2011/05/19/10

http://openwall.com/lists/oss-security/2011/05/19/5

http://secunia.com/advisories/44558

http://secunia.com/advisories/44613

http://secunia.com/advisories/44661

http://secunia.com/advisories/44780

http://secunia.com/advisories/48308

http://www.mandriva.com/security/advisories?name=MDVSA-2011:095

http://www.redhat.com/support/errata/RHSA-2011-0844.html

http://www.vupen.com/english/advisories/2011/1289

http://www.vupen.com/english/advisories/2011/1290

https://issues.apache.org/bugzilla/show_bug.cgi?id=51219

Details

Source: MITRE

Published: 2011-05-24

Updated: 2018-01-06

Type: CWE-399

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (21 total)

IDNameProductFamilySeverity
75785openSUSE Security Update : apache2 (openSUSE-SU-2011:0859-1)NessusSuSE Local Security Checks
medium
75424openSUSE Security Update : apache2 (openSUSE-SU-2011:0859-1)NessusSuSE Local Security Checks
medium
74066GLSA-201405-24 : Apache Portable Runtime, APR Utility Library: Denial of ServiceNessusGentoo Local Security Checks
medium
68284Oracle Linux 4 / 5 / 6 : apr (ELSA-2011-0844)NessusOracle Linux Local Security Checks
medium
61053Scientific Linux Security Update : apr on SL6.x i386/x86_64NessusScientific Linux Local Security Checks
medium
61052Scientific Linux Security Update : apr on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
medium
58811HP System Management Homepage < 7.0 Multiple VulnerabilitiesNessusWeb Servers
critical
57215SuSE 10 Security Update : libapr1 (ZYPP Patch Number 7610)NessusSuSE Local Security Checks
medium
55566SuSE 10 Security Update : libapr (ZYPP Patch Number 7611)NessusSuSE Local Security Checks
medium
55564SuSE 11.1 Security Update : libapr (SAT Patch Number 4845)NessusSuSE Local Security Checks
medium
55563SuSE 11.1 Security Update : libapr (SAT Patch Number 4845)NessusSuSE Local Security Checks
medium
55095Ubuntu 6.06 LTS / 8.04 LTS / 10.04 LTS / 10.10 / 11.04 : apache2, apr vulnerabilities (USN-1134-1)NessusUbuntu Local Security Checks
medium
54958Fedora 13 : apr-1.4.5-1.fc13 (2011-7340)NessusFedora Local Security Checks
medium
54957Fedora 14 : apr-1.4.5-1.fc14 (2011-6918)NessusFedora Local Security Checks
medium
54944Fedora 15 : apr-1.4.5-1.fc15 (2011-6750)NessusFedora Local Security Checks
medium
54938CentOS 4 / 5 : apr (CESA-2011:0844)NessusCentOS Local Security Checks
medium
54932RHEL 4 / 5 / 6 : apr (RHSA-2011:0844)NessusRed Hat Local Security Checks
medium
54648Slackware 11.0 / 12.0 / 12.1 / 12.2 / 13.0 / 13.1 / 13.37 / current : apr/apr-util (SSA:2011-145-01)NessusSlackware Local Security Checks
medium
54646Apache 2.2.x < 2.2.18 APR apr_fnmatch DoSNessusWeb Servers
medium
54623FreeBSD : Apache APR -- DoS vulnerabilities (99a5590c-857e-11e0-96b7-00300582f9fc)NessusFreeBSD Local Security Checks
medium
54610Mandriva Linux Security Advisory : apr (MDVSA-2011:095-1)NessusMandriva Local Security Checks
medium