Mailman < 2.1.14 Multiple XSS

low Nessus Plugin ID 54579
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A web application on the remote host has multiple cross-site scripting vulnerabilities.


According to its self-reported version number, the Mailman installation running on the remote host has multiple cross-site scripting vulnerabilities. These vulnerabilities can reportedly only be exploited by a list owner.

A malicious list owner could exploit these issues to execute arbitrary script code in another user's browser.


Upgrade to Mailman 2.1.14 or later.

See Also

Plugin Details

Severity: Low

ID: 54579

File Name: mailman_2_1_14.nasl

Version: 1.8

Type: remote

Published: 5/19/2011

Updated: 1/19/2021

Dependencies: mailman_detect.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Low

Base Score: 3.5

Temporal Score: 3

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:gnu:mailman:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, www/Mailman

Exploit Ease: No exploit is required

Patch Publication Date: 9/9/2010

Vulnerability Publication Date: 9/5/2010

Reference Information

CVE: CVE-2010-3089

BID: 43187

CWE: 20, 79, 74, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990