FreeBSD : Postfix -- memory corruption vulnerability (3eb2c100-738b-11e0-89f4-001e90d46635)

Medium Nessus Plugin ID 53852


The remote FreeBSD host is missing one or more security-related updates.


The Postfix SMTP server has a memory corruption error, when the Cyrus SASL library is used with authentication mechanisms other than PLAIN and LOGIN (ANONYMOUS is not affected, but should not be used for other reasons). This memory corruption is known to result in a program crash (SIGSEV).


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 53852

File Name: freebsd_pkg_3eb2c100738b11e089f4001e90d46635.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2011/05/10

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:postfix, p-cpe:/a:freebsd:freebsd:postfix-base, p-cpe:/a:freebsd:freebsd:postfix-current, p-cpe:/a:freebsd:freebsd:postfix-current-base, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2011/05/09

Vulnerability Publication Date: 2011/05/09

Reference Information

CVE: CVE-2011-1720