openSUSE Security Update : opera (openSUSE-SU-2011:0103-1)

High Nessus Plugin ID 53787


The remote openSUSE host is missing a security update.


Opera 11.01 fixes several critical security bugs :

- CVE-2011-0681: CVSS v2 Base Score: 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:P/A:N): Other (CWE-Other)

- CVE-2011-0682: CVSS v2 Base Score: 9.3 (HIGH) (AV:N/AC:M/Au:N/C:C/I:C/A:C): Buffer Errors (CWE-119)

- CVE-2011-0683: CVSS v2 Base Score: 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:P/A:N): Other (CWE-Other)

- CVE-2011-0684: CVSS v2 Base Score: 7.8 (HIGH) (AV:N/AC:L/Au:N/C:C/I:N/A:N): Input Validation (CWE-20)

- CVE-2011-0685: CVSS v2 Base Score: 3.6 (LOW) (AV:L/AC:L/Au:N/C:P/I:P/A:N): Input Validation (CWE-20)

- CVE-2011-0686: CVSS v2 Base Score: 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P): Insufficient Information (CWE-noinfo)

- CVE-2011-0687: CVSS v2 Base Score: 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:N/A:P): Input Validation (CWE-20)


Update the affected opera packages.

See Also

Plugin Details

Severity: High

ID: 53787

File Name: suse_11_2_opera-110204.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2011/05/05

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:opera, p-cpe:/a:novell:opensuse:opera-gtk, p-cpe:/a:novell:opensuse:opera-kde4, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/02/04

Reference Information

CVE: CVE-2011-0681, CVE-2011-0682, CVE-2011-0683, CVE-2011-0684, CVE-2011-0685, CVE-2011-0686, CVE-2011-0687