openSUSE Security Update : libopensc2 (openSUSE-SU-2011:0049-1)

High Nessus Plugin ID 53748


The remote openSUSE host is missing a security update.


Specially crafted smart cards could cause a buffer overflow in opensc (CVE-2010-4523).


Update the affected libopensc2 packages.

See Also

Plugin Details

Severity: High

ID: 53748

File Name: suse_11_2_libopensc2-101222.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2011/05/05

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libopensc2, p-cpe:/a:novell:opensuse:libopensc2-32bit, p-cpe:/a:novell:opensuse:opensc, p-cpe:/a:novell:opensuse:opensc-32bit, p-cpe:/a:novell:opensuse:opensc-devel, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/12/22

Reference Information

CVE: CVE-2010-4523