openSUSE Security Update : hplip (openSUSE-SU-2011:0068-1)

High Nessus Plugin ID 53730


The remote openSUSE host is missing a security update.


Specially crafted SNMP replies could cause a buffer overflow in hplip's sane backend (CVE-2010-4267).


Update the affected hplip packages.

See Also

Plugin Details

Severity: High

ID: 53730

File Name: suse_11_2_hplip-110117.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2011/05/05

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:hplip, p-cpe:/a:novell:opensuse:hplip-hpijs, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/01/17

Reference Information

CVE: CVE-2010-4267