openSUSE Security Update : git (openSUSE-SU-2011:0115-1)

High Nessus Plugin ID 53727


The remote openSUSE host is missing a security update.


This update fixes two vulnerabilities :

XSS vulnerability in gitweb; a remote attacker could craft an URL such that arbitrary content would be inserted to the generated web page.

Stack overflow vulnerability that can lead to arbitrary code execution if user runs any git command on a specially crafted git working copy.

Security Issue references :

- [CVE-2010-3906]( e=CVE-2010-3906)

- [CVE-2010-2542]( e=CVE-2010-2542)


Update the affected git packages.

See Also

Plugin Details

Severity: High

ID: 53727

File Name: suse_11_2_git-110117.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2011/05/05

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:git, p-cpe:/a:novell:opensuse:git-arch, p-cpe:/a:novell:opensuse:git-core, p-cpe:/a:novell:opensuse:git-cvs, p-cpe:/a:novell:opensuse:git-daemon, p-cpe:/a:novell:opensuse:git-email, p-cpe:/a:novell:opensuse:git-gui, p-cpe:/a:novell:opensuse:git-svn, p-cpe:/a:novell:opensuse:git-web, p-cpe:/a:novell:opensuse:gitk, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/01/17

Reference Information

CVE: CVE-2010-2542, CVE-2010-3906