openSUSE Security Update : exim (openSUSE-SU-2010:1052-1)

High Nessus Plugin ID 53715


The remote openSUSE host is missing a security update.


remote attackers could trick exim into running arbitrary code (CVE-2010-4344). A privilege escalation flaw allowed attackers to gain root access (CVE-2010-4345).


Update the affected exim packages.

See Also

Plugin Details

Severity: High

ID: 53715

File Name: suse_11_2_exim-101211.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2011/05/05

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:exim, p-cpe:/a:novell:opensuse:eximon, p-cpe:/a:novell:opensuse:eximstats-html, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/12/11

Exploitable With


Core Impact

Metasploit (Exim4 string_format Function Heap Buffer Overflow)

Reference Information

CVE: CVE-2010-4344, CVE-2010-4345