openSUSE Security Update : kdegraphics3 (openSUSE-SU-2010:1035-1)

high Nessus Plugin ID 53665
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

Various pointer dereferencing vulnerabilities in kdegraphics3's KSVG have been fixed. CVE-2009-1709 and CVE-2009-0945 have been assigned to this issue.

Solution

Update the affected kdegraphics3 packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=512559

https://bugzilla.novell.com/show_bug.cgi?id=600469

https://lists.opensuse.org/opensuse-updates/2010-12/msg00020.html

Plugin Details

Severity: High

ID: 53665

File Name: suse_11_1_kdegraphics3-101104.nasl

Version: 1.7

Type: local

Agent: unix

Published: 5/5/2011

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:kdegraphics3, p-cpe:/a:novell:opensuse:kdegraphics3-3D, p-cpe:/a:novell:opensuse:kdegraphics3-devel, p-cpe:/a:novell:opensuse:kdegraphics3-extra, p-cpe:/a:novell:opensuse:kdegraphics3-fax, p-cpe:/a:novell:opensuse:kdegraphics3-imaging, p-cpe:/a:novell:opensuse:kdegraphics3-kamera, p-cpe:/a:novell:opensuse:kdegraphics3-pdf, p-cpe:/a:novell:opensuse:kdegraphics3-postscript, p-cpe:/a:novell:opensuse:kdegraphics3-scan, p-cpe:/a:novell:opensuse:kdegraphics3-tex, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 11/4/2010

Reference Information

CVE: CVE-2009-0945, CVE-2009-1709

CWE: 94, 399