IBM Lotus Domino iCalendar Email Address ORGANIZER:mailto Header Remote Overflow

high Nessus Plugin ID 53534
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote mail service is affected by a remote stack-based buffer overflow vulnerability.

Description

According to its self-reported version, the remote SMTP service is an instance of IBM Lotus Domino that is is affected by a remote stack-based buffer overflow vulnerability because it fails to perform adequate boundary checks on user-supplied input.

Successfully exploiting this issue may allow remote attackers to execute arbitrary code in the context of the 'nrouter.exe' Lotus Domino server process. Failed attacks will cause denial of service conditions.

Solution

Upgrade to IBM Lotus Domino 8.0.2 FP5 / 8.5.1 FP2 / 8.5.2 or later.

See Also

http://www.nessus.org/u?a5dee6ba

http://www.nessus.org/u?d7d5efdc

http://www.nessus.org/u?6fa36abe

http://www.nessus.org/u?8072500a

http://www.nessus.org/u?b1c391a1

http://www.nessus.org/u?cd9e7c99

Plugin Details

Severity: High

ID: 53534

File Name: lotus_domino_icalendar_safe.nasl

Version: 1.16

Type: remote

Published: 4/22/2011

Updated: 11/15/2018

Dependencies: smtpserver_detect.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:lotus_domino

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/14/2010

Vulnerability Publication Date: 9/14/2010

Exploitable With

CANVAS (D2ExploitPack)

Core Impact

Metasploit (IBM Lotus Domino iCalendar MAILTO Buffer Overflow)

Reference Information

CVE: CVE-2010-3407

BID: 43219