MediaWiki API XSS

medium Nessus Plugin ID 53449
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server hosts a version of MediaWiki that is affected by a cross-site scripting vulnerability.

Description

A cross-site scripting vulnerability exists in this installation of MediaWiki that allows an attacker to execute arbitrary script code in the browser of an unsuspecting user. Such script code could steal authentication credentials and be used to launch other attacks.

Solution

Upgrade to MediaWiki 1.16.4 or later.

See Also

http://www.nessus.org/u?bb194760

https://phabricator.wikimedia.org/T30507

Plugin Details

Severity: Medium

ID: 53449

File Name: mediawiki_1_16_4.nasl

Version: 1.11

Type: remote

Published: 4/15/2011

Updated: 1/19/2021

Dependencies: mediawiki_detect.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: installed_sw/MediaWiki, www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 4/14/2011

Vulnerability Publication Date: 4/12/2011

Reference Information

CVE: CVE-2011-1587

BID: 47354

Secunia: 44142

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990