MediaWiki Backslash Escaped CSS Comments XSS

medium Nessus Plugin ID 53448


The remote web server hosts a version of MediaWiki that is affected by a cross-site vulnerability.


This installation of MediaWiki is affected by a cross-site scripting vulnerability that allows an attacker to execute arbitrary script code in the browser of an unsuspecting user. Such script code can steal authentication credentials and be used to launch other attacks.

This version of MediaWiki may also contain a second cross-site scripting and/or an unauthorized access vulnerability, but this plugin did not test for these vulnerabilities.


Upgrade to MediaWiki 1.16.3 or later.

See Also

Plugin Details

Severity: Medium

ID: 53448

File Name: mediawiki_1_16_3.nasl

Version: 1.14

Type: remote

Published: 4/15/2011

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Low

Score: 3.4


Risk Factor: Medium

Base Score: 5.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: installed_sw/MediaWiki, www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 4/12/2011

Vulnerability Publication Date: 4/12/2011

Reference Information

CVE: CVE-2011-1579

BID: 47354

SECUNIA: 44142

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990