FreeBSD : krb5 -- MITKRB5-SA-2011-001, kpropd denial of service (64f24a1e-66cf-11e0-9deb-f345f3aa24f0)

Medium Nessus Plugin ID 53441


The remote FreeBSD host is missing one or more security-related updates.


An advisory published by the MIT Kerberos team says :

The MIT krb5 KDC database propagation daemon (kpropd) is vulnerable to a denial-of-service attack triggered by invalid network input. If a kpropd worker process receives invalid input that causes it to exit with an abnormal status, it can cause the termination of the listening process that spawned it, preventing the slave KDC it was running on from receiving database updates from the master KDC.

Exploit code is not known to exist, but the vulnerabilities are easy to trigger manually.

An unauthenticated remote attacker can cause kpropd running in standalone mode (the '-S' option) to terminate its listening process, preventing database propagations to the KDC host on which it was running. Configurations where kpropd runs in incremental propagation mode ('iprop') or as an inetd server are not affected.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 53441

File Name: freebsd_pkg_64f24a1e66cf11e09debf345f3aa24f0.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2011/04/15

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:krb5, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2011/04/14

Vulnerability Publication Date: 2011/02/08

Reference Information

CVE: CVE-2010-4022