SuSE 11.1 Security Update : moonlight (SAT Patch Number 4246)

Medium Nessus Plugin ID 53314


The remote SuSE 11 host is missing one or more security updates.


Moonlight was prone to several security problems :

- modification of read-only values via RuntimeHelpers.InitializeArray. (CVE-2011-0989)

- buffer overflow due to race condition in in Array.FastCopy. (CVE-2011-0990)

- use-after-free due to DynamicMethod resurrection.

- information leak due to improper thread finalization These issues have been fixed. (CVE-2011-0992)


Apply SAT patch number 4246.

See Also

Plugin Details

Severity: Medium

ID: 53314

File Name: suse_11_libmoon-devel-110329.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2011/04/07

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libmoon0, p-cpe:/a:novell:suse_linux:11:moonlight-plugin, p-cpe:/a:novell:suse_linux:11:moonlight-tools, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/03/29

Reference Information

CVE: CVE-2011-0989, CVE-2011-0990, CVE-2011-0991, CVE-2011-0992