SuSE 11.1 Security Update : PostgreSQL (SAT Patch Number 3977)

Medium Nessus Plugin ID 53230


The remote SuSE 11 host is missing one or more security updates.


A buffer overflow in the intarray module potentially allowed attackers to execute arbitrary code as the user running PostgreSQL (CVE-2010-4015: CVSS v2 Base Score: 4.9). Additionally a possible log forging problem was fixed too. (CVE-2010-4014)


Apply SAT patch number 3977.

See Also

Plugin Details

Severity: Medium

ID: 53230

File Name: suse_11_postgresql-110217.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2011/03/31

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:postgresql, p-cpe:/a:novell:suse_linux:11:postgresql-contrib, p-cpe:/a:novell:suse_linux:11:postgresql-docs, p-cpe:/a:novell:suse_linux:11:postgresql-libs, p-cpe:/a:novell:suse_linux:11:postgresql-libs-32bit, p-cpe:/a:novell:suse_linux:11:postgresql-server, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/02/17

Reference Information

CVE: CVE-2010-4014, CVE-2010-4015