FreeBSD : linux-flashplugin -- remote code execution vulnerability (501ee07a-5640-11e0-985a-001b2134ef46)

High Nessus Plugin ID 52966


The remote FreeBSD host is missing one or more security-related updates.


Adobe Product Security Incident Response Team reports :

A critical vulnerability exists in Adobe Flash Player and earlier versions (Adobe Flash Player and earlier for Chrome users) for Windows, Macintosh, Linux and Solaris operating systems, Adobe Flash Player and earlier versions for Android, and the Authplay.dll component that ships with Adobe Reader and Acrobat X (10.0.1) and earlier 10.x and 9.x versions of Reader and Acrobat for Windows and Macintosh operating systems.

This vulnerability (CVE-2011-0609) could cause a crash and potentially allow an attacker to take control of the affected system. There are reports that this vulnerability is being exploited in the wild in targeted attacks via a Flash (.swf) file embedded in a Microsoft Excel (.xls) file delivered as an email attachment.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 52966

File Name: freebsd_pkg_501ee07a564011e0985a001b2134ef46.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2011/03/25

Modified: 2013/11/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-f10-flashplugin, p-cpe:/a:freebsd:freebsd:linux-f8-flashplugin, p-cpe:/a:freebsd:freebsd:linux-flashplugin, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/03/24

Vulnerability Publication Date: 2011/01/20

Exploitable With

Core Impact

Metasploit (Adobe Flash Player AVM Bytecode Verification Vulnerability)

Reference Information

CVE: CVE-2011-0609