SuSE 11 Security Update : Websphere Community Edition (SAT Patch Number 1016)

High Nessus Plugin ID 52690

Synopsis

The remote SuSE 11 host is missing a security update.

Description

This update of WebSphere fixes the following vulnerabilities :

- GERONIMO-3838: close potential denial of service attack

- fix Apache Geronimo web administration console directory traversal vulnerabilities. (CVE-2008-5518)

- fix Apache Geronimo web administration console XSS vulnerabilities. (CVE-2009-0038)

- fix Apache Geronimo web administration console CSRF vulnerabilities. (CVE-2009-0039)

- Samples: Fix Apache Tomcat cross-site scripting vulnerability. (CVE-2009-0781)

Solution

Apply SAT patch number 1016.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=507806

http://support.novell.com/security/cve/CVE-2008-5518.html

http://support.novell.com/security/cve/CVE-2009-0038.html

http://support.novell.com/security/cve/CVE-2009-0039.html

http://support.novell.com/security/cve/CVE-2009-0781.html

Plugin Details

Severity: High

ID: 52690

File Name: suse_11_websphere-as_ce-090619.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2011/03/17

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:websphere-as_ce, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/06/19

Reference Information

CVE: CVE-2008-5518, CVE-2009-0038, CVE-2009-0039, CVE-2009-0781

CWE: 22, 79, 352