MediaWiki CSS Comments XSS

medium Nessus Plugin ID 51998
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server hosts a version of MediaWiki vulnerable to a cross-site scripting attack.

Description

There is a cross-site scripting vulnerability in this installation of MediaWiki that may allow an attacker to execute arbitrary script code in the browser of an unsuspecting user. Such script code could steal authentication credentials and be used to launch other attacks.

This version of MediaWiki also contains a local file inclusion vulnerability that is exploitable when running Microsoft Windows, but this plugin did not test for that vulnerability.

Solution

Upgrade to MediaWiki 1.16.2 or later.

See Also

http://www.nessus.org/u?5c3c879f

https://bugzilla.wikimedia.org/show_bug.cgi?id=27093

https://bugzilla.wikimedia.org/show_bug.cgi?id=27094

Plugin Details

Severity: Medium

ID: 51998

File Name: mediawiki_1_16_2.nasl

Version: 1.11

Type: remote

Published: 2/16/2011

Updated: 1/19/2021

Dependencies: mediawiki_detect.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: installed_sw/MediaWiki, www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 2/1/2011

Vulnerability Publication Date: 2/1/2011

Reference Information

CVE: CVE-2011-0047

BID: 46108

Secunia: 43142

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990