WordPress < 3.0.5 Multiple Vulnerabilities

medium Nessus Plugin ID 51939


The remote web server contains a PHP application with multiple vulnerabilities.


According to its version number, the installation of WordPress hosted on the remote web server is affected by multiple vulnerabilities :

- The application is prone to multiple cross-site scripting vulnerabilities. An attacker can exploit these issues through the 'title' field of the 'Quick/Bulk Edit' section and the 'tags meta box' section. An attacker would require Author or Contributor privileges to take advantage of this.

- The application is prone to an information disclosure vulnerability. An attacker can exploit this issue through the media uploader to disclose posts.
This information may assist in further attacks. An attacker would require Author privileges to take advantage of this.

Note that Nessus has not tested for the issues but has instead relied only on the application's self-reported version number.


Upgrade to WordPress 3.0.5 or later.

See Also



Plugin Details

Severity: Medium

ID: 51939

File Name: wordpress_3_0_5.nasl

Version: 1.19

Type: remote

Family: CGI abuses

Published: 2/10/2011

Updated: 6/5/2024

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Low

Score: 3.0


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2011-3818

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP, Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Patch Publication Date: 2/7/2011

Vulnerability Publication Date: 2/7/2011

Reference Information

CVE: CVE-2011-0700, CVE-2011-0701, CVE-2011-3818

BID: 46249

CWE: 20, 442, 629, 711, 712, 722, 725, 74, 750, 751, 79, 800, 801, 809, 811, 864, 900, 928, 931, 990

Secunia: 43238