WordPress < 3.0.2 Multiple Vulnerabilities

medium Nessus Plugin ID 51860
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server hosts a PHP application that is affected by multiple vulnerabilities.


According to its version number, the installation of WordPress hosted on the remote web server is affected by multiple vulnerabilities :

- A SQL injection vulnerability exists in the 'wp-includes/comment.php' script due to improper sanitization of user-supplied input to the 'Send Trackbacks' field. A remote attacker can exploit this to inject or manipulate SQL queries to manipulate or disclose arbitrary data. (CVE-2010-4257)

- A cross-site scripting vulnerability exists in the request_filesystem_credentials() function in the 'wp-admin/includes/file.php' script where input passed from an error message for an FTP or SSH connection attempt is not validated. This allows a context-dependent attacker to use a specially crafted request to execute arbitrary script code within the user's browser session. (CVE-2010-5294)

- A cross-site scripting vulnerability exists in the 'wp-admin/plugins.php' script due to improper validation of input supplied via a plugin's 'author' field. This allows a remote attacker to inject arbitrary script or HTML code in a user's browser session. (CVE-2010-5295)

- A security bypass vulnerability exists in the 'wp-includes/capabilities.php' script. When a multisite configuration is used, Super Admin privileges are not needed for the 'delete_users' capability. This allows an authenticated attacker to bypass access restrictions.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to WordPress 3.0.2 or later.

See Also




Plugin Details

Severity: Medium

ID: 51860

File Name: wordpress_3_0_2.nasl

Version: 1.19

Type: remote

Family: CGI abuses

Published: 2/3/2011

Updated: 1/19/2021

Dependencies: wordpress_detect.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6

Temporal Score: 4.4

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 11/30/2010

Vulnerability Publication Date: 9/4/2010

Reference Information

CVE: CVE-2010-4257, CVE-2010-5294, CVE-2010-5295, CVE-2010-5296, CVE-2010-5293

BID: 45131, 65233, 65240, 73661, 65235

Secunia: 42431

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990