SuSE 11.1 Security Update : pcsc-lite (SAT Patch Number 3889)

Medium Nessus Plugin ID 51844


The remote SuSE 11 host is missing one or more security updates.


An integer overflow in pcsc-ccid and a buffer overflow in pcsc-lite while handling smart card responses have been fixed.

CVE-2010-4530 / CVE-2010-4531 have been assigned to these issues.
Additionally a new device ID for card readers was added.


Apply SAT patch number 3889.

See Also

Plugin Details

Severity: Medium

ID: 51844

File Name: suse_11_pcsc-ccid-110121.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2011/02/02

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:pcsc-ccid, p-cpe:/a:novell:suse_linux:11:pcsc-lite, p-cpe:/a:novell:suse_linux:11:pcsc-lite-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/01/21

Reference Information

CVE: CVE-2010-4530, CVE-2010-4531