SuSE 10 Security Update : acroread_ja (ZYPP Patch Number 6161)

Critical Nessus Plugin ID 51705


The remote SuSE 10 host is missing a security-related patch.


Multiple flaws in the JBIG2 decoder and the JavaScript engine of the Adobe Reader allowed attackers to crash acroread or even execute arbitrary code by tricking users into opening specially crafted PDF files.

(CVE-2009-0658 / CVE-2009-0927 / CVE-2009-0193 / CVE-2009-0928 / CVE-2009-1061 / CVE-2009-1062)


Apply ZYPP patch number 6161.

See Also

Plugin Details

Severity: Critical

ID: 51705

File Name: suse_acroread_ja-6161.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2011/01/27

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/15

Exploitable With


Core Impact

Metasploit (Adobe Collab.getIcon() Buffer Overflow)

Reference Information

CVE: CVE-2009-0193, CVE-2009-0658, CVE-2009-0927, CVE-2009-0928, CVE-2009-1061, CVE-2009-1062

CWE: 20, 119