SuSE 10 Security Update : Python (ZYPP Patch Number 7314)

High Nessus Plugin ID 51642


The remote SuSE 10 host is missing a security-related patch.


With this update of Python :

- a race condition in the accept() implementation of could lead to a denial of service.

- integer overflows and insufficient size checks could crash the audioop and rgbimg modules. (CVE-2010-2089 / CVE-2010-1634 / CVE-2009-4134 / CVE-2010-1449 / CVE-2010-1450)


Apply ZYPP patch number 7314.

See Also

Plugin Details

Severity: High

ID: 51642

File Name: suse_python-7314.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2011/01/21

Modified: 2012/05/17

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/01/15

Reference Information

CVE: CVE-2009-4134, CVE-2010-1449, CVE-2010-1450, CVE-2010-1634, CVE-2010-2089, CVE-2010-3493