SuSE 11.1 Security Update : libvirt (SAT Patch Number 2957)

Medium Nessus Plugin ID 51624


The remote SuSE 11 host is missing one or more security updates.


libvirt did not properly handle configured disk formats which potentially allowed users to read arbitrary files. (CVE-2010-2237 / CVE-2010-2238 / CVE-2010-2239)

Improperly mapped source privileged ports in guests may allow obtaining privileged resources on the host. (CVE-2010-2242)

In addition, fixes for the following non-security issues were included :

- libvirt based kvm guest save operation takes too long.

- With greater than 37 CPUs virt-manager throws exceptions. (bnc#609738)

- Stopping more than one VirtualDomain will fail.

- Unable to install SLES 9 SP4 guest from CDs on KVM system. (bnc#626070)


Apply SAT patch number 2957.

See Also

Plugin Details

Severity: Medium

ID: 51624

File Name: suse_11_libvirt-100819.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2011/01/21

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.4

Vector: CVSS2#AV:L/AC:M/Au:S/C:C/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libvirt, p-cpe:/a:novell:suse_linux:11:libvirt-doc, p-cpe:/a:novell:suse_linux:11:libvirt-python, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/08/19

Reference Information

CVE: CVE-2010-2237, CVE-2010-2238, CVE-2010-2239, CVE-2010-2242