SuSE 11.1 Security Update : openLDAP (SAT Patch Number 2551)

Medium Nessus Plugin ID 51616


The remote SuSE 11 host is missing one or more security updates.


Several issues have been fixed in OpenLDAP :

- specially crafted MODRDN operations can crash the OpenLDAP server. (CVE-2010-0211 / CVE-2010-0212)

- syncrepl might loose deletes in refreshAndPersist mode


Apply SAT patch number 2551.

See Also

Plugin Details

Severity: Medium

ID: 51616

File Name: suse_11_libldap-2_4-2-100616.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2011/01/21

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libldap-2_4-2, p-cpe:/a:novell:suse_linux:11:libldap-2_4-2-32bit, p-cpe:/a:novell:suse_linux:11:openldap2, p-cpe:/a:novell:suse_linux:11:openldap2-back-meta, p-cpe:/a:novell:suse_linux:11:openldap2-client, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/16

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-0211, CVE-2010-0212