SuSE 11.1 Security Update : ed (SAT Patch Number 3792)

High Nessus Plugin ID 51597


The remote SuSE 11 host is missing a security update.


This update fixes a heap-based buffer overflow in ed which can be exploited remotely only with user-assistance. CVE-2008-3916: CVSS v2 Base Score: 9.3 (HIGH) (AV:N/AC:M/Au:N/C:C/I:C/A:C): Buffer Errors.


Apply SAT patch number 3792.

See Also

Plugin Details

Severity: High

ID: 51597

File Name: suse_11_ed-110111.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2011/01/21

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:ed, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/01/11

Reference Information

CVE: CVE-2008-3916

CWE: 119