FreeBSD : tor -- remote code execution and crash (38bdf10e-2293-11e0-bfa4-001676740879)

Medium Nessus Plugin ID 51560


The remote FreeBSD host is missing one or more security-related updates.


The Tor Project reports :

A remote heap overflow vulnerability that can allow remote code execution. Other fixes address a variety of assert and crash bugs, most of which we think are hard to exploit remotely. All Tor users should upgrade.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 51560

File Name: freebsd_pkg_38bdf10e229311e0bfa4001676740879.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2011/01/18

Modified: 2016/05/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:tor, p-cpe:/a:freebsd:freebsd:tor-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/01/17

Vulnerability Publication Date: 2011/01/15

Reference Information

CVE: CVE-2011-0427

BID: 45832