FreeBSD : php -- corruption of $GLOBALS and $this variables via extract() method (f3148a05-0fa7-11e0-becc-0022156e8794)

High Nessus Plugin ID 51508


The remote FreeBSD host is missing one or more security-related updates.


Off-by-one error in the sanity validator for the extract() method allowed attackers to replace the values of $GLOBALS and $this when mode EXTR_OVERWRITE was used.


Update the affected packages.

See Also[email protected]/msg47722.html

Plugin Details

Severity: High

ID: 51508

File Name: freebsd_pkg_f3148a050fa711e0becc0022156e8794.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2011/01/13

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:php5, p-cpe:/a:freebsd:freebsd:php52, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2011/01/13

Vulnerability Publication Date: 2010/12/10