Git gitweb Multiple Parameter XSS

Medium Nessus Plugin ID 51370

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.8

Synopsis

The remote web server hosts a CGI script that is prone to a cross- site scripting attack.

Description

The version of gitweb, a web-enabled interface to the open source distributed version control system Git, hosted on the remote web server fails to sanitize user-supplied input to the 'f' and 'fp' parameters before using it to generate dynamic HTML.

An attacker may be able to leverage this issue to inject arbitrary HTML or script code into a user's browser to be executed within the security context of the affected site.

Solution

Upgrade to Git 1.7.3.4 or later.

See Also

https://lists.q42.co.uk/pipermail/git-announce/2011-August/000450.html

Plugin Details

Severity: Medium

ID: 51370

File Name: gitweb_f_xss.nasl

Version: 1.10

Type: remote

Published: 2010/12/23

Updated: 2018/11/15

Dependencies: 10107

Risk Information

Risk Factor: Medium

VPR Score: 3.8

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:git:git

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2010/12/15

Vulnerability Publication Date: 2010/12/15

Reference Information

CVE: CVE-2010-3906

BID: 45439

EDB-ID: 15744

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990