SuSE 11 / 11.1 Security Update : libgdiplus0 (SAT Patch Numbers 2999 / 3000)

Medium Nessus Plugin ID 50932


The remote SuSE 11 host is missing a security update.


This update fixes three integer overflows found by Secunia Research member Stefan Cornelius that could possibly be exploited to execute arbitrary code :

- gdip_load_tiff_image() by processing specially crafted TIFF images

- gdip_load_jpeg_image_internal() by processing specially crafted JPEG images

- gdip_read_bmp_image() by processing specially crafted BMP image


Apply SAT patch number 2999 / 3000 as appropriate.

See Also

Plugin Details

Severity: Medium

ID: 50932

File Name: suse_11_libgdiplus0-100824.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2010/12/02

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libgdiplus0, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/08/24

Reference Information

CVE: CVE-2010-1526