SuSE 11 / 11.1 Security Update : clamav (SAT Patch Numbers 2479 / 2480)

Medium Nessus Plugin ID 50897


The remote SuSE 11 host is missing one or more security updates.


This update fixes the following security issues in clamav that can be used as a remote denial of service attack :

- A off-by-one buffer overflow. (CVE-2010-1640)

- A crash while parsing PDFs (CVE-2010-1639 / CVE-2010-2077)


Apply SAT patch number 2479 / 2480 as appropriate.

See Also

Plugin Details

Severity: Medium

ID: 50897

File Name: suse_11_clamav-100526.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2010/12/02

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:clamav, p-cpe:/a:novell:suse_linux:11:libstdc++43, p-cpe:/a:novell:suse_linux:11:libstdc++43-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/05/26

Reference Information

CVE: CVE-2010-1639, CVE-2010-1640