Ubuntu 8.04 LTS / 9.10 / 10.04 LTS / 10.10 : xulrunner-1.9.1, xulrunner-1.9.2 vulnerability (USN-1011-3)

high Nessus Plugin ID 50412

Language:

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

USN-1011-1 fixed a vulnerability in Firefox. This update provides the corresponding update for Xulrunner.

Morten Krakvik discovered a heap-based buffer overflow in Firefox. If a user were tricked into navigating to a malicious site, an attacker could cause a denial of service or possibly execute arbitrary code as the user invoking the program.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://usn.ubuntu.com/1011-3/

Plugin Details

Severity: High

ID: 50412

File Name: ubuntu_USN-1011-3.nasl

Version: 1.17

Type: local

Agent: unix

Published: 10/29/2010

Updated: 9/19/2019

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Critical

Score: 9.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.1, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.1-dbg, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.1-dev, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.1-gnome-support, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.1-testsuite, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.1-testsuite-dev, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.2, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.2-dbg, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.2-dev, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.2-gnome-support, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.2-testsuite, p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.2-testsuite-dev, p-cpe:/a:canonical:ubuntu_linux:xulrunner-dev, cpe:/o:canonical:ubuntu_linux:10.04:-:lts, cpe:/o:canonical:ubuntu_linux:10.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts, cpe:/o:canonical:ubuntu_linux:9.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/28/2010

Vulnerability Publication Date: 10/27/2010

Exploitable With

CANVAS (CANVAS)

Metasploit (Mozilla Firefox Interleaved document.write/appendChild Memory Corruption)

Reference Information

CVE: CVE-2010-3765

BID: 44425

USN: 1011-3