FreeBSD : opera -- multiple vulnerabilities (aab187d4-e0f3-11df-b1ea-001999392805)

High Nessus Plugin ID 50351


The remote FreeBSD host is missing a security-related update.


The Opera Desktop Team reports :

- Fixed an issue that allowed cross-domain checks to be bypassed, allowing limited data theft using CSS, as reported by Isaac Dawson.

- Fixed an issue where manipulating the window could be used to spoof the page address.

- Fixed an issue with reloads and redirects that could allow spoofing and cross-site scripting.

- Fixed an issue that allowed private video streams to be intercepted, as reported by Nirankush Panchbhai of Microsoft Vulnerability Research.

- Fixed an issue that caused JavaScript to run in the wrong security context after manual interaction.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 50351

File Name: freebsd_pkg_aab187d4e0f311dfb1ea001999392805.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2010/10/27

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:opera, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2010/10/26

Vulnerability Publication Date: 2010/10/12