openSUSE Security Update : OpenOffice_org-draw (openSUSE-SU-2010:0732-1)

High Nessus Plugin ID 50012

Synopsis

The remote openSUSE host is missing a security update.

Description

Specially crafted ppt files could cause a heap based buffer overflow in OpenOffice_org Impress. Attackers could exploit that to crash OpenOffice_org or potentially even execute arbitrary code (CVE-2010-2935, CVE-2010-2936).

Solution

Update the affected OpenOffice_org-draw packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=629085

https://lists.opensuse.org/opensuse-updates/2010-10/msg00020.html

Plugin Details

Severity: High

ID: 50012

File Name: suse_11_1_OpenOffice_org-draw-100906.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2010/10/18

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:OpenOffice_org-draw, p-cpe:/a:novell:opensuse:OpenOffice_org-impress, p-cpe:/a:novell:opensuse:OpenOffice_org-impress-devel, p-cpe:/a:novell:opensuse:OpenOffice_org-impress-l10n-prebuilt, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-gui, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-gui-devel, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-gui-l10n-prebuilt, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/09/06

Reference Information

CVE: CVE-2010-2935, CVE-2010-2936