FreeBSD : phpmyfaq -- XSS vulnerabilities (99021f88-ca3c-11df-be21-00e018aa7788)

High Nessus Plugin ID 49730


The remote FreeBSD host is missing a security-related update.


The phpMyFAQ project reports :

The phpMyFAQ Team has learned of a security issue that has been discovered in phpMyFAQ 2.6.x: phpMyFAQ doesn't sanitize some variables in different pages correctly. With a properly crafted URL it is e.g.
possible to inject JavaScript code into the output of a page, which could result in the leakage of domain cookies (f.e. session identifiers)..


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 49730

File Name: freebsd_pkg_99021f88ca3c11dfbe2100e018aa7788.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2010/10/06

Modified: 2014/09/18

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:phpmyfaq, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2010/10/02

Vulnerability Publication Date: 2010/09/28