Squid < 3.1.8 / NULL Pointer Dereference Denial of Service

medium Nessus Plugin ID 49693
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote proxy server is affected by a denial of service vulnerability.


According to its banner, the version of Squid is 3.x earlier than than 3.1.8, or 3.2.x earlier than Such versions are potentially affected by a denial of service vulnerability caused by an internal error in string handling. A remote attacker, exploiting this flaw, could crash the affected service.

Note that Nessus has relied only on the version in the proxy server's banner, which is not updated by either of the patches the project has released to address the issue. If one of those has been applied properly and the service restarted, consider this to be a false positive.


Upgrade to Squid version 3.1.8 / or later.

See Also


Plugin Details

Severity: Medium

ID: 49693

File Name: squid_3_1_8.nasl

Version: 1.9

Type: remote

Family: Firewalls

Published: 9/28/2010

Updated: 7/30/2018

Dependencies: squid_version.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/3/2010

Vulnerability Publication Date: 9/3/2010

Reference Information

CVE: CVE-2010-3072

BID: 42982

Secunia: 41298