FreeBSD : linux-flashplugin -- remote code execution (8a34d9e6-c662-11df-b2e1-001b2134ef46)

High Nessus Plugin ID 49652


The remote FreeBSD host is missing one or more security-related updates.


Adobe Product Security Incident Response Team reports :

A critical vulnerability exists in Adobe Flash Player and earlier versions for Windows, Macintosh, Linux, Solaris, and Adobe Flash Player for Android. This vulnerability also affects Adobe Reader 9.3.4 and earlier versions for Windows, Macintosh and UNIX, and Adobe Acrobat 9.3.4 and earlier versions for Windows and Macintosh. This vulnerability (CVE-2010-2884) could cause a crash and potentially allow an attacker to take control of the affected system.
There are reports that this vulnerability is being actively exploited in the wild against Adobe Flash Player on Windows. Adobe is not aware of any attacks exploiting this vulnerability against Adobe Reader or Acrobat to date.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 49652

File Name: freebsd_pkg_8a34d9e6c66211dfb2e1001b2134ef46.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2010/09/23

Modified: 2013/11/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-f10-flashplugin, p-cpe:/a:freebsd:freebsd:linux-f8-flashplugin, p-cpe:/a:freebsd:freebsd:linux-flashplugin, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/09/22

Vulnerability Publication Date: 2010/09/14

Exploitable With


Core Impact

Reference Information

CVE: CVE-2010-2884