openSUSE Security Update : tgt (openSUSE-SU-2010:0608-1)

Medium Nessus Plugin ID 49216


The remote openSUSE host is missing a security update.


This update of iscscitarget/tgt fixes multiple overflows and a format string vulnerability :

- CVE-2010-2221: CVSS v2 Base Score: 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P): Buffer Errors (CWE-119)

- CVE-2010-0743: CVSS v2 Base Score: 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P): Format String Vulnerability (CWE-134)


Update the affected tgt package.

See Also

Plugin Details

Severity: Medium

ID: 49216

File Name: suse_11_2_tgt-100805.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2010/09/14

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:tgt, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/08/05

Reference Information

CVE: CVE-2010-0743, CVE-2010-2221