MySQL Community Server < 5.1.49 Multiple Vulnerabilities

medium Nessus Plugin ID 48759
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL Community Server installed on the remote host is earlier than 5.1.49 and thus potentially affected by multiple vulnerabilities:

- DDL statements could cause the server to crash. (55039)

- Joins involving a table with a unique SET column could cause the server to crash. (54575)

- Incorrect handling of NULL arguments for IN or CASE operations involving the WITH ROLLUP modifier could cause the server to crash. (54477)

- A malformed argument to the BINLOG statement could cause the server to crash. (54393)

- Using TEMPORARY InnoDB tables with nullable columns could cause the server to crash. (54044)

- Alternate reads with two indexes on a table using the HANDLER interface could cause the server to crash.
(54007)

- Using EXPLAIN with queries of the form SELECT ... UNION ... ORDER BY (SELECT ... WHERE ...) could cause the server to crash. (52711)

- LOAD DATA INFILE did not check for SQL errors sent and even if errors were already reported, it sent an OK packet. Also, an assert was sometimes raised when it should not have been relating to client-server protocol checking in debug servers. (52512)

Solution

Upgrade to MySQL Community Server 5.1.49 or later.

See Also

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-49.html

https://bugs.mysql.com/bug.php?id=52711

https://bugs.mysql.com/bug.php?id=54007

https://bugs.mysql.com/bug.php?id=54044

https://bugs.mysql.com/bug.php?id=55039

https://bugs.mysql.com/bug.php?id=55475

https://bugs.mysql.com/bug.php?id=54477

https://bugs.mysql.com/bug.php?id=54393

https://bugs.mysql.com/bug.php?id=52512

Plugin Details

Severity: Medium

ID: 48759

File Name: mysql_5_1_49.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 8/26/2010

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 7/9/2010

Vulnerability Publication Date: 7/9/2010

Reference Information

CVE: CVE-2010-3677, CVE-2010-3678, CVE-2010-3680, CVE-2010-3681, CVE-2010-3682, CVE-2010-3679, CVE-2010-3683, CVE-2010-3676

BID: 42598, 42599, 42633, 42646, 42596, 42625, 42638, 42643

Secunia: 41048