Squid 3.1.6 DNS Reply Denial of Service

medium Nessus Plugin ID 48433
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote proxy server is affected by a denial of service vulnerability.

Description

According to its banner, the version of the Squid proxy caching server installed on the remote host is 3.1.6. This version is affected by a denial of service vulnerability that is caused by an assertion failure when contacting IPv4-only DNS resolvers.

Note that Nessus has relied only on the version in the proxy server's banner, which is not updated by either of the patches the project has released to address this issue. If one of those has been applied properly and the service restarted, consider this to be a false positive.

Solution

Upgrade to Squid version 3.1.7 or later

See Also

https://bugs.squid-cache.org/show_bug.cgi?id=3021

http://www.squid-cache.org/mail-archive/squid-users/201008/0480.html

Plugin Details

Severity: Medium

ID: 48433

File Name: squid_3_1_7.nasl

Version: 1.14

Type: remote

Family: Firewalls

Published: 8/25/2010

Updated: 11/15/2018

Dependencies: squid_version.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 8/24/2010

Vulnerability Publication Date: 8/24/2010

Reference Information

CVE: CVE-2010-2951

BID: 42645