Mac OS X Multiple Vulnerabilities (Security Update 2010-005)

High Nessus Plugin ID 48424

Synopsis

The remote host is missing a Mac OS X update that fixes security issues.

Description

The remote host is running a version of Mac OS X 10.6 or 10.5 that does not have Security Update 2010-005 applied.

This security update contains fixes for the following products :

- ATS
- CFNetwork
- ClamAV
- CoreGraphics
- libsecurity
- PHP
- Samba

Solution

Install Security Update 2010-005 or later.

See Also

http://support.apple.com/kb/HT4312

http://lists.apple.com/archives/security-announce/2010/Aug/msg00003.html

Plugin Details

Severity: High

ID: 48424

File Name: macosx_SecUpd2010-005.nasl

Version: 1.14

Type: local

Agent: macosx

Published: 2010/08/24

Updated: 2018/07/14

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:apple:mac_os_x

Required KB Items: Host/MacOSX/packages, Host/uname

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/08/24

Vulnerability Publication Date: 2010/03/12

Exploitable With

Metasploit (Samba chain_reply Memory Corruption (Linux x86))

Reference Information

CVE: CVE-2010-0098, CVE-2010-0397, CVE-2010-1129, CVE-2010-1205, CVE-2010-1311, CVE-2010-1800, CVE-2010-1801, CVE-2010-1802, CVE-2010-1808, CVE-2010-2063, CVE-2010-2225, CVE-2010-2484, CVE-2010-2531

BID: 38708, 39262, 40884, 40948, 41174, 42651, 42652, 42653, 42655