openSUSE Security Update : gpg2 (openSUSE-SU-2010:0479-1)

Medium Nessus Plugin ID 48260


The remote openSUSE host is missing a security update.


GnuPG2 was vulnerable to arbitrary code execution by context-dependent attackers because of reusing a freed pointer when verifying a signature or importing a certificate with many 'Subject Alternate Names'. (CVE-2010-2547)


Update the affected gpg2 packages.

See Also

Plugin Details

Severity: Medium

ID: 48260

File Name: suse_11_2_gpg2-100728.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2010/08/06

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gpg2, p-cpe:/a:novell:opensuse:gpg2-lang, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/07/28

Reference Information

CVE: CVE-2010-2547