FreeBSD : libmspack -- infinite loop denial of service (43024078-9b63-11df-8983-001d60d86f38)

High Nessus Plugin ID 47904


The remote FreeBSD host is missing one or more security-related updates.


There is a denial of service vulnerability in libmspack. The libmspack code is built into cabextract, so it is also vulnerable.

Secunia reports :

The vulnerability is caused due to an error when copying data from an uncompressed block (block type 0) and can be exploited to trigger an infinite loop by tricking an application using the library into processing specially crafted MS-ZIP archives.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 47904

File Name: freebsd_pkg_430240789b6311df8983001d60d86f38.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2010/07/30

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:cabextract, p-cpe:/a:freebsd:freebsd:libmspack, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2010/07/30

Vulnerability Publication Date: 2010/07/26

Reference Information

Secunia: 40719