openSUSE Security Update : openldap2 (openSUSE-SU-2010:0427-1)

Medium Nessus Plugin ID 47819


The remote openSUSE host is missing a security update.


The following issues have been fixed in OpenLDAP: specially crafted MODRDN operations can crash the OpenLDAP server (CVE-2010-0211 and CVE-2010-0212).


Update the affected openldap2 packages.

See Also

Plugin Details

Severity: Medium

ID: 47819

File Name: suse_11_0_openldap2-100712.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2010/07/26

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:openldap2, p-cpe:/a:novell:opensuse:openldap2-back-meta, p-cpe:/a:novell:opensuse:openldap2-back-perl, p-cpe:/a:novell:opensuse:openldap2-client, p-cpe:/a:novell:opensuse:openldap2-client-32bit, p-cpe:/a:novell:opensuse:openldap2-devel, p-cpe:/a:novell:opensuse:openldap2-devel-32bit, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/07/12

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-0211, CVE-2010-0212